mirror of
https://git.freebsd.org/ports.git
synced 2025-05-20 19:13:27 -04:00
Makefile bump PORTREVISION; USE_CSTD: gnu89 became gnu99 [0]; files/ *: if ARCH=i386, replaces ARCH with ia32; elf_ia32_efi.lds: sync OUTPUT_FORMAT [1]; MokManager.c: used UINT32 for MokNum. Reported by: pkg-fallout Approved by: araujo (mentor) Differential Revision: https://reviews.freebsd.org/D18572 [0] shim.c:2176:3: error: this decimal constant is unsigned only in ISO C90 [1] patch-elf_x86_64_efi.lds always appended -freebsd as OUTPUT_FORMAT
13 lines
312 B
Text
13 lines
312 B
Text
--- lib/Makefile.orig 2015-06-30 18:20:12 UTC
|
|
+++ lib/Makefile
|
|
@@ -1,3 +1,10 @@
|
|
+ifeq ($(ARCH),amd64)
|
|
+ override ARCH = x86_64
|
|
+endif
|
|
+ifeq ($(ARCH),i386)
|
|
+ override ARCH = ia32
|
|
+endif
|
|
+
|
|
TARGET = lib.a
|
|
|
|
LIBFILES = simple_file.o guid.o console.o execute.o configtable.o shell.o variables.o security_policy.o
|