mirror of
https://git.freebsd.org/ports.git
synced 2025-05-14 08:11:50 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
32 lines
1 KiB
C++
32 lines
1 KiB
C++
# Allow fake device file to use with fstab(5)
|
|
|
|
--- src/simple-mtpfs-fuse.cpp.orig 2015-08-24 11:34:39 UTC
|
|
+++ src/simple-mtpfs-fuse.cpp
|
|
@@ -309,12 +309,6 @@ bool SMTPFileSystem::parseOptions(int ar
|
|
|
|
--m_options.m_device_no;
|
|
|
|
- // device file and -- device are mutually exclusive, fail if both set
|
|
- if (m_options.m_device_no && m_options.m_device_file) {
|
|
- m_options.m_good = false;
|
|
- return false;
|
|
- }
|
|
-
|
|
m_options.m_good = true;
|
|
return true;
|
|
}
|
|
@@ -379,11 +373,9 @@ bool SMTPFileSystem::exec()
|
|
return false;
|
|
}
|
|
|
|
- if (m_options.m_device_file) {
|
|
- // Try to use device file first, if provided
|
|
- if (!m_device.connect(m_options.m_device_file))
|
|
- return false;
|
|
- } else {
|
|
+ // Try to use device file first, ignore otherwise
|
|
+ if (!m_options.m_device_file ||
|
|
+ !m_device.connect(m_options.m_device_file)) {
|
|
// Connect to MTP device by order number, if no device file supplied
|
|
if (!m_device.connect(m_options.m_device_no))
|
|
return false;
|