ports/sysutils/conky/files/patch-lua_CMakeLists.txt
Fernando Apesteguía f9c6c779d5 sysutils/conky{-awesome}: update to 0.120.2
ChangeLog: https://github.com/brndnmtthws/conky/releases/tag/v1.20.2

Features

 * Separate cairo-xlib.h Lua bindings from cairo.h
 * Cleanup build flags, global namespace and includes
 * Use perfect hash (gperf) for parsing color names
 * set_struts improvements

Bug fixes

 * Fix imlib_cache_size_setting::lua_setter

Miscellaneous

 * Bump version
 * Annoyingly, the artifacts go into a subdir
 * Always run Nix & AppImage builds on PRs
 * Track more context labels
 * Fix matrix URL
 * Revert "Fix matrix URL"
 * Fix web components and pages (UI)
2024-04-29 08:34:22 +02:00

11 lines
411 B
Text

--- lua/CMakeLists.txt.orig 2024-04-24 13:56:28 UTC
+++ lua/CMakeLists.txt
@@ -28,6 +28,8 @@ if(BUILD_LUA_CAIRO)
if(BUILD_LUA_CAIRO)
include_directories(${luacairo_includes} ${CMAKE_CURRENT_SOURCE_DIR})
+ link_directories(${LIBS})
+
# cairo_set_dash() needs this special hack to work properly if you have a
# better solution, please let me know
wrap_tolua(luacairo_src cairo.pkg libcairo.patch)