mirror of
https://git.freebsd.org/ports.git
synced 2025-05-14 08:11:50 -04:00
* Under the hood runs Chromium 87.0.4280.144 with security fixes up to
version 96.0.4664.110 and patches were taken from of www/chromium
87.0.4280.141 (391acded85
).
* Prune some unneeded patches (mostly from the headless and unittest
areas) and try to align the unbundling of dependencies similar to
qt6-webengine for consistency.
* Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles
has changed since Qt 5.15.3.
Tested by: tcberner
Differential Revision: https://reviews.freebsd.org/D38165
96 lines
3.5 KiB
Text
96 lines
3.5 KiB
Text
--- src/3rdparty/chromium/BUILD.gn.orig 2021-12-15 16:12:54 UTC
|
|
+++ src/3rdparty/chromium/BUILD.gn
|
|
@@ -423,7 +423,7 @@ group("gn_all") {
|
|
]
|
|
}
|
|
|
|
- if (is_linux || is_chromeos || is_android) {
|
|
+ if ((is_linux && !is_bsd) || is_chromeos || is_android) {
|
|
deps += [
|
|
"//third_party/breakpad:breakpad_unittests",
|
|
"//third_party/breakpad:core-2-minidump",
|
|
@@ -464,8 +464,6 @@ group("gn_all") {
|
|
"//net:disk_cache_memory_test",
|
|
"//net:quic_client",
|
|
"//net:quic_server",
|
|
- "//sandbox/linux:chrome_sandbox",
|
|
- "//sandbox/linux:sandbox_linux_unittests",
|
|
"//testing:empty_main",
|
|
]
|
|
|
|
@@ -520,10 +518,6 @@ group("gn_all") {
|
|
"//chrome/test:load_library_perf_tests",
|
|
"//chrome/test:sync_performance_tests",
|
|
"//chrome/test/chromedriver:chromedriver",
|
|
- "//courgette:courgette",
|
|
- "//courgette:courgette_fuzz",
|
|
- "//courgette:courgette_minimal_tool",
|
|
- "//courgette:courgette_unittests",
|
|
"//media/cast:generate_barcode_video",
|
|
"//media/cast:generate_timecode_audio",
|
|
"//net:crash_cache",
|
|
@@ -595,10 +589,6 @@ group("gn_all") {
|
|
"//mojo:mojo_perftests",
|
|
"//services/service_manager/public/cpp",
|
|
"//testing/gmock:gmock_main",
|
|
- "//third_party/breakpad:dump_syms($host_toolchain)",
|
|
- "//third_party/breakpad:microdump_stackwalk($host_toolchain)",
|
|
- "//third_party/breakpad:minidump_dump($host_toolchain)",
|
|
- "//third_party/breakpad:minidump_stackwalk($host_toolchain)",
|
|
]
|
|
|
|
if (!is_android) {
|
|
@@ -676,7 +666,7 @@ group("gn_all") {
|
|
host_os == "win" && !use_qt) {
|
|
deps += [ "//chrome/test/mini_installer:mini_installer_tests" ]
|
|
}
|
|
- } else if (!is_android && !is_ios && !is_fuchsia && !is_win) {
|
|
+ } else if (!is_android && !is_ios && !is_fuchsia && !is_win && !is_bsd) {
|
|
deps += [ "//third_party/breakpad:symupload($host_toolchain)" ]
|
|
}
|
|
|
|
@@ -691,7 +681,7 @@ group("gn_all") {
|
|
}
|
|
}
|
|
|
|
- if (is_mac || is_win || is_android || (is_linux && !is_chromeos)) {
|
|
+ if (is_mac || is_win || is_android || (is_linux && !is_chromeos && !is_bsd)) {
|
|
deps += [
|
|
"//third_party/crashpad/crashpad:crashpad_tests",
|
|
"//third_party/crashpad/crashpad/handler:crashpad_handler",
|
|
@@ -810,7 +800,6 @@ group("gn_all") {
|
|
"//chrome/browser/vr:vr_common_perftests",
|
|
"//chrome/browser/vr:vr_common_unittests",
|
|
"//chrome/browser/vr:vr_pixeltests",
|
|
- "//tools/perf/contrib/vr_benchmarks:vr_perf_tests",
|
|
]
|
|
if (is_android) {
|
|
deps += [ "//chrome/browser/android/vr:vr_android_unittests" ]
|
|
@@ -1103,7 +1092,7 @@ if (!is_ios && !use_qt) {
|
|
data_deps += [ "//content/web_test:web_test_common_mojom_js_data_deps" ]
|
|
}
|
|
|
|
- if (!is_win && !is_android) {
|
|
+ if (!is_win && !is_android && !is_bsd) {
|
|
data_deps +=
|
|
[ "//third_party/breakpad:minidump_stackwalk($host_toolchain)" ]
|
|
}
|
|
@@ -1112,7 +1101,7 @@ if (!is_ios && !use_qt) {
|
|
data_deps += [ "//third_party/breakpad:dump_syms($host_toolchain)" ]
|
|
}
|
|
|
|
- if (is_linux || is_chromeos) {
|
|
+ if ((is_linux && !is_bsd) || is_chromeos) {
|
|
data_deps += [ "//third_party/breakpad:dump_syms($host_toolchain)" ]
|
|
}
|
|
|
|
@@ -1308,9 +1297,6 @@ group("chromium_builder_perf") {
|
|
|
|
if (is_win) {
|
|
data_deps += [ "//chrome/installer/mini_installer:mini_installer" ]
|
|
- } else {
|
|
- data_deps +=
|
|
- [ "//third_party/breakpad:minidump_stackwalk($host_toolchain)" ]
|
|
}
|
|
if (is_win || is_android) {
|
|
data_deps += [
|