ports/textproc/py-sphinxcontrib-bitbucket/files/patch-setup.py
Kubilay Kocak eb9b6ef201 textproc/py-sphinxcontrib-bitbucket: Fix Python 3 build/run
Fix Python 3 build, identified while testing devel/py-virtualenvwrapper:

Exception occurred:
  File "/usr/local/lib/python3.7/site-packages/sphinx/registry.py", line 196, in load_extension
    mod = __import__(extname, None, None, ['setup'])
  File "/usr/local/lib/python3.7/site-packages/sphinxcontrib/bitbucket.py", line 26
    except AttributeError, err:
                         ^
SyntaxError: invalid syntax

While I'm here, level up ports/python compliance:

  - Add python to CATEGORIES
  - Add LICENSE/LICENSE_FILE
  - Add NO_ARCH
  - Add missing RUN_DEPENDS
  - Correct RUN_DEPENDS version-specs

Approved by:	portmgr (blanket(s): build fix, ports compliance, dependencies)
MFH:		2019Q3
2019-08-12 01:11:25 +00:00

18 lines
430 B
Python

--- setup.py.orig 2011-04-24 16:19:59 UTC
+++ setup.py
@@ -1,9 +1,5 @@
# -*- coding: utf-8 -*-
-# Bootstrap installation of Distribute
-import distribute_setup
-distribute_setup.use_setuptools()
-
from setuptools import setup, find_packages
try:
@@ -43,5 +39,4 @@ setup(
include_package_data=True,
install_requires=requires,
namespace_packages=['sphinxcontrib'],
- py_modules = [ 'distribute_setup' ],
)