mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
65 lines
3.4 KiB
Text
65 lines
3.4 KiB
Text
# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
|
|
# Submitted by: koobs (r326729)
|
|
# TODO: Upstream
|
|
--- Makefile.pre.in.orig 2019-11-04 01:16:37 UTC
|
|
+++ Makefile.pre.in
|
|
@@ -80,7 +80,6 @@ MAKESETUP= $(srcdir)/Modules/makesetup
|
|
OPT= @OPT@
|
|
BASECFLAGS= @BASECFLAGS@
|
|
BASECPPFLAGS= @BASECPPFLAGS@
|
|
-CONFIGURE_CFLAGS= @CFLAGS@
|
|
# CFLAGS_NODIST is used for building the interpreter and stdlib C extensions.
|
|
# Use it when a compiler flag should _not_ be part of the distutils CFLAGS
|
|
# once Python is installed (Issue #21121).
|
|
@@ -89,18 +88,16 @@ CONFIGURE_CFLAGS_NODIST=@CFLAGS_NODIST@
|
|
# Use it when a linker flag should _not_ be part of the distutils LDFLAGS
|
|
# once Python is installed (bpo-35257)
|
|
CONFIGURE_LDFLAGS_NODIST=@LDFLAGS_NODIST@
|
|
-CONFIGURE_CPPFLAGS= @CPPFLAGS@
|
|
-CONFIGURE_LDFLAGS= @LDFLAGS@
|
|
# Avoid assigning CFLAGS, LDFLAGS, etc. so users can use them on the
|
|
# command line to append to these values without stomping the pre-set
|
|
# values.
|
|
-PY_CFLAGS= $(BASECFLAGS) $(OPT) $(CONFIGURE_CFLAGS) $(CFLAGS) $(EXTRA_CFLAGS)
|
|
+PY_CFLAGS= $(BASECFLAGS) $(OPT) $(CFLAGS) $(EXTRA_CFLAGS)
|
|
PY_CFLAGS_NODIST=$(CONFIGURE_CFLAGS_NODIST) $(CFLAGS_NODIST) -I$(srcdir)/Include/internal
|
|
# Both CPPFLAGS and LDFLAGS need to contain the shell's value for setup.py to
|
|
# be able to build extension modules using the directories specified in the
|
|
# environment variables
|
|
-PY_CPPFLAGS= $(BASECPPFLAGS) -I. -I$(srcdir)/Include $(CONFIGURE_CPPFLAGS) $(CPPFLAGS)
|
|
-PY_LDFLAGS= $(CONFIGURE_LDFLAGS) $(LDFLAGS)
|
|
+PY_CPPFLAGS= $(BASECPPFLAGS) -I. -I$(srcdir)/Include $(CPPFLAGS)
|
|
+PY_LDFLAGS= $(LDFLAGS)
|
|
PY_LDFLAGS_NODIST=$(CONFIGURE_LDFLAGS_NODIST) $(LDFLAGS_NODIST)
|
|
NO_AS_NEEDED= @NO_AS_NEEDED@
|
|
SGI_ABI= @SGI_ABI@
|
|
@@ -1269,14 +1266,6 @@ bininstall: altbininstall
|
|
else true; \
|
|
fi
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python3$(EXE))
|
|
- -if test "$(VERSION)" != "$(LDVERSION)"; then \
|
|
- rm -f $(DESTDIR)$(BINDIR)/python$(VERSION)-config; \
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(LDVERSION)-config python$(VERSION)-config); \
|
|
- rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION).pc; \
|
|
- (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python-$(LDVERSION).pc); \
|
|
- rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION)-embed.pc; \
|
|
- (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION)-embed.pc python-$(LDVERSION)-embed.pc); \
|
|
- fi
|
|
-rm -f $(DESTDIR)$(BINDIR)/python3-config
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python3-config)
|
|
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
|
|
@@ -1580,6 +1569,14 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
|
$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
|
|
$(INSTALL_SCRIPT) python-config.py $(DESTDIR)$(LIBPL)/python-config.py
|
|
$(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(LDVERSION)-config
|
|
+ -if test "$(VERSION)" != "$(LDVERSION)"; then \
|
|
+ rm -f $(DESTDIR)$(BINDIR)/python$(VERSION)-config; \
|
|
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(LDVERSION)-config python$(VERSION)-config); \
|
|
+ rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION).pc; \
|
|
+ (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python-$(LDVERSION).pc); \
|
|
+ rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION)-embed.pc; \
|
|
+ (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION)-embed.pc python-$(LDVERSION)-embed.pc); \
|
|
+ fi
|
|
@if [ -s Modules/python.exp -a \
|
|
"`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
|
|
echo; echo "Installing support files for building shared extension modules on AIX:"; \
|