mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
This megacommit merges all the work from https://github.com/freebsd/freebsd-ports-kde/tree/kde-it_goes_to_6 Specifically: - KDE Plasma 6 ports updated to 6.2.5 - KDE Applications ports updated to 24.12.0 - Development ports of KDE Applications removed - A lot of various ports switched to Qt 6 by default - Some KDE Frameworks 5 and Plasma 5 ports are adapted to be coinstallable with their 6 counterparts PR: 284351 Exp-run by: antoine Pull Request: https://github.com/freebsd/freebsd-ports/pull/341 Co-authored-by: Max Brazhnikov <makc@FreeBSD.org> Co-authored-by: Kenneth Raplee <kenrap@kennethraplee.com> Co-authored-by: Jason E. Hale <jhale@FreeBSD.org> Co-authored-by: Gleb Popov <arrowd@FreeBSD.org>
16 lines
601 B
Text
16 lines
601 B
Text
The OSS4 backend doesn't currently work on FreeBSD. Use the OSS3 backend
|
|
as a fallback instead.
|
|
|
|
PR: 273476
|
|
|
|
--- CMakeLists.txt.orig 2024-12-02 23:31:44 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -135,7 +135,7 @@ if (HAVE_SOUNDCARD_H OR HAVE_SYS_SOUNDCARD_H)
|
|
#message(STATUS "OSS3_COMPILE_RESULT= ${OSS3_COMPILE_RESULT}")
|
|
#message(STATUS "OSS4_COMPILE_RESULT= ${OSS4_COMPILE_RESULT}")
|
|
|
|
- if (${OSS4_COMPILE_RESULT})
|
|
+ if (${OSS4_COMPILE_RESULT} AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
message(STATUS "Building with OSS 4 support")
|
|
set(HAVE_OSS_4 true)
|
|
add_definitions(-DHAVE_OSS_4)
|