ports/textproc/py-elasticsearch5/files/patch-setup.py
Kubilay Kocak 1bd7ef4f32 textproc/py-elasticsearch5: Remove pinned urllib3 version
elasticsearch5 (this port) unnecessarily pins its urllib dependency to
< 1.23, which blocks updating urllib3 to 1.24 [1]:

./textproc/py-elasticsearch5: setup.py: 'urllib3<1.23,>=1.21.1',

The package had a history of issues/conflicts/bugs with the urllib3
dependency, ultimately resulting in the maximum version pin being
removed [2]:

  https://github.com/elastic/elasticsearch-py/issues/807
  https://github.com/elastic/elasticsearch-py/issues/667
  https://github.com/elastic/elasticsearch-py/issues/634

This commit backports that change, a functional noop and sweeping change
in advance required for a urllib3 update, and adds TEST_DEPENDS and
a test target to support rigorous and confident QA. Switching to GitHub
sources was required as the PyPI sdist does not package tests.

The packages tests all pass with/against urllib3 1.24 installed, with an
intermittent and non-deterministic off-by-one failure in one test:

FAIL: test_all_chunks_sent (test_elasticsearch.test_helpers.TestParallelBulk)

The issue exists independent of urllib3 version. The flaky test issue was
reported upstream [3], but was not resolved.

[2] 4352e56174
[3] https://github.com/elastic/elasticsearch-py/issues/701

PR:		229322 [1]
Approved by:	portmgr (blanket: framework compliance, runtime bugfix)
2019-04-16 04:06:27 +00:00

14 lines
386 B
Python

# fixing max urllib3, updating authors
# https://github.com/elastic/elasticsearch-py/commit/4352e56174b77560d2f86801cb1ad32440bb2d32
--- setup.py.orig 2019-01-21 08:52:05 UTC
+++ setup.py
@@ -12,7 +12,7 @@ long_description = f.read().strip()
f.close()
install_requires = [
- 'urllib3<1.23,>=1.21.1',
+ 'urllib3>=1.21.1',
]
tests_require = [
'requests>=2.0.0, <3.0.0',