ports/filesystems/ods2/files/patch-direct.c
Robert Clausecker 29d06d4836 sysutils/ods2: move to filesystems/ods2
- tool manipulates VMS file systems
 - add timestamp to distinfo to satisfy post-receive hook

Approved by:	portmgr (infrastructure blanket)
2024-11-14 09:42:58 +01:00

24 lines
828 B
C

--- direct.c.orig 2001-08-31 18:01:07 UTC
+++ direct.c
@@ -136,12 +136,15 @@ int name_match(char *spec,int spec_len,char *dirent,in
register char sch = *name;
if (sch != '*') {
register char ech = *entry;
- if (sch != ech) if (toupper(sch) != toupper(ech))
- if (sch == '%') {
- percent = MAT_NE;
- } else {
- break;
- }
+ if (sch != ech) {
+ if (toupper(sch) != toupper(ech)) {
+ if (sch == '%') {
+ percent = MAT_NE;
+ } else {
+ break;
+ }
+ }
+ }
} else {
break;
}