ports/www/py-adblock/files/patch-tests_test__metadata.py
Adam Jimerson 9bc4543e96 www/py-adblock: Update version 0.5.0=>0.6.0
Changelog: https://github.com/ArniDagur/python-adblock/releases/tag/0.6.0

PR:		275479
Approved by:	submitter is maintainer
2023-12-08 08:25:21 +01:00

16 lines
786 B
Python

--- tests/test_metadata.py.orig 2023-11-30 00:16:36 UTC
+++ tests/test_metadata.py
@@ -57,10 +57,10 @@ def test_required_python_version():
Make sure that the Python interpreter we're running this test suite on
falls into the required Python range.
"""
- with open("Cargo.toml", encoding="utf-8") as f:
- cargo_toml = toml.loads(f.read())
+ with open("pyproject.toml", encoding="utf-8") as f:
+ pyproject_toml = toml.loads(f.read())
- required_python = cargo_toml["package"]["metadata"]["maturin"]["requires-python"]
+ required_python = pyproject_toml["project"]["requires-python"]
assert required_python.startswith(">=")
required_python = required_python[2:]
assert get_current_python_version() >= parse_version(required_python)