ports/editors/nvi2/files/patch-CMakeLists.txt
Craig Leres ab0fed1b91 editors/nvi2: Update to 26-Apr-2024 (52c07e8)
- In ruler show the current line number as a percentage of the
   total lines

 - Link macro for hyperlink

 - Add showfilename set option

 - Fix undefined string comparison

 - Replace Clang-only __builtin_is_aligned with C code

 - Use memmove to realign buffers
2025-01-14 13:01:28 -08:00

10 lines
430 B
Text

--- CMakeLists.txt.orig 2023-09-25 08:47:42 UTC
+++ CMakeLists.txt
@@ -37,7 +37,6 @@ add_compile_options($<$<CONFIG:Release>:-Wno-dangling-
endif()
add_compile_options($<$<CONFIG:Release>:-Wuninitialized>)
add_compile_options($<$<CONFIG:Release>:-Wno-dangling-else>)
-add_compile_options(-Wno-string-compare)
add_compile_options(-Wstack-protector -fstack-protector)
add_compile_options(-Wstrict-aliasing -fstrict-aliasing)