ports/x11/tabbed/files/patch-config.mk
Baptiste Daroussin 16cdb8a0f3 x11/tabbed: reduce patching
Repect PREFIX and CC by using MAKE_ARGS instead of patching
While here move manpages to share/man
2024-01-11 09:55:24 +01:00

18 lines
480 B
Makefile

--- config.mk.orig 2014-01-21 18:22:03 UTC
+++ config.mk
@@ -8,12 +8,12 @@ MANPREFIX = ${PREFIX}/share/man
MANPREFIX = ${PREFIX}/share/man
# includes and libs
-INCS = -I. -I/usr/include
-LIBS = -L/usr/lib -lc -lX11
+INCS = -I. -I${LOCALBASE}/include
+LIBS = -L${LOCALBASE}/lib -lX11
# flags
CPPFLAGS = -DVERSION=\"${VERSION}\" -D_BSD_SOURCE
-CFLAGS = -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+CFLAGS += -Wall ${INCS} ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
# Solaris