mirror of
https://git.freebsd.org/ports.git
synced 2025-05-01 02:56:39 -04:00
This needs c++11 compiler. GCC from ports doesn't support -Weverything. PR: 239332 Approved by: hyun@caffeinated.codes (maintainer), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D21145
11 lines
490 B
Text
11 lines
490 B
Text
--- libsweep/CMakeLists.txt.orig 2019-07-20 09:46:23 UTC
|
|
+++ libsweep/CMakeLists.txt
|
|
@@ -19,7 +19,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
|
set(libsweep_OS unix)
|
|
|
|
elseif(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
|
|
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Weverything -fvisibility=hidden -fPIC -fno-rtti")
|
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -fvisibility=hidden -fPIC -fno-rtti")
|
|
set(libsweep_OS unix)
|
|
|
|
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
|