mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 03:56:39 -04:00
50 lines
2.1 KiB
Text
50 lines
2.1 KiB
Text
--- CMakeLists.txt.orig 2022-12-31 21:52:21 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -242,7 +242,7 @@ elseif(CMAKE_COMPILER_IS_GNUCXX)
|
|
if(GCC_VERSION VERSION_LESS 7.3.0)
|
|
message(FATAL_ERROR "The installed g++ version is ${GCC_VERSION}. ${PROJECT_NAME} requires g++ 7.3.0 or greater.")
|
|
endif()
|
|
- set(CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG")
|
|
+ set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG")
|
|
set(CMAKE_CXX_FLAGS_DEBUG "-g -fno-omit-frame-pointer -fno-inline-functions -fno-inline-functions-called-once -fno-optimize-sibling-calls")
|
|
if(DART_FAST_DEBUG)
|
|
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O1")
|
|
@@ -270,7 +270,7 @@ elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang")
|
|
if("${CMAKE_SYSTEM_NAME}" MATCHES "Darwin")
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
|
|
endif()
|
|
- set(CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG")
|
|
+ set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG")
|
|
set(CMAKE_CXX_FLAGS_DEBUG "-g -fno-omit-frame-pointer -fno-inline-functions -fno-optimize-sibling-calls")
|
|
if(DART_FAST_DEBUG)
|
|
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O1")
|
|
@@ -338,20 +338,20 @@ if(TARGET dart)
|
|
if(MSVC)
|
|
add_subdirectory(examples)
|
|
else()
|
|
- add_subdirectory(examples EXCLUDE_FROM_ALL)
|
|
- get_property(examples GLOBAL PROPERTY DART_EXAMPLES)
|
|
- add_custom_target(examples DEPENDS ${examples})
|
|
+ #add_subdirectory(examples EXCLUDE_FROM_ALL)
|
|
+ #get_property(examples GLOBAL PROPERTY DART_EXAMPLES)
|
|
+ #add_custom_target(examples DEPENDS ${examples})
|
|
endif()
|
|
|
|
if(DART_VERBOSE)
|
|
message(STATUS "")
|
|
message(STATUS "[ Examples ]")
|
|
- foreach(example ${examples})
|
|
- message(STATUS "Adding example: ${example}")
|
|
- endforeach(example ${examples})
|
|
- else(DART_VERBOSE)
|
|
- list(LENGTH examples examples_length)
|
|
- message(STATUS "Adding ${examples_length} examples")
|
|
+ #foreach(example ${examples})
|
|
+ # message(STATUS "Adding example: ${example}")
|
|
+ #endforeach(example ${examples})
|
|
+ #else(DART_VERBOSE)
|
|
+ #list(LENGTH examples examples_length)
|
|
+ #message(STATUS "Adding ${examples_length} examples")
|
|
endif(DART_VERBOSE)
|
|
|
|
# Add a "tutorials" target to build tutorials.
|