mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 10:36:38 -04:00
- Remove all references to defunct ARCH arm - Remove all references to defunct ARCH sparc64 - Remove x11-drivers/xf86-video-sunffb which requires defunct sparc64 ARCH - Remove sysutils/afbinit requires defunct sparc64 ARCH - Remove all references to bktr driver - Remove all references to defunct FreeBSD_12 - Remove all references to OSVERSION/OSREL corresponding to 12 - Remove conditionals in Mk/Uses/cabal.mk - Remove sparc reference from Mk/Uses/qt-dist.mk - Remove BROKEN_sparc64/NOT_FOR_ARCH=sparc64 - Remove BROKEN_FreeBSD_12* from: - Remove OpenSSL patches from: - Remove conditional flags for OSVERSION >= 1300000 to fixed flags. Also move conditional flags for non sparc64/arm ARCH to fixed flags. Reviewed by: brooks, jbeich, rene, salvadore Differential Revision: https://reviews.freebsd.org/D42068
11 lines
483 B
C++
11 lines
483 B
C++
--- src/client/qwaylandshmbackingstore.cpp.orig 2023-10-04 20:59:02 UTC
|
|
+++ src/client/qwaylandshmbackingstore.cpp
|
|
@@ -82,6 +82,8 @@ QWaylandShmBuffer::QWaylandShmBuffer(QWaylandDisplay *
|
|
fd = syscall(SYS_memfd_create, "wayland-shm", MFD_CLOEXEC | MFD_ALLOW_SEALING);
|
|
if (fd >= 0)
|
|
fcntl(fd, F_ADD_SEALS, F_SEAL_SHRINK | F_SEAL_SEAL);
|
|
+#elif defined(__FreeBSD__)
|
|
+ fd = memfd_create("wayland-shm", MFD_CLOEXEC);
|
|
#endif
|
|
|
|
QScopedPointer<QFile> filePointer;
|