ports/graphics/libyuv/files/patch-CMakeLists.txt
Jan Beich 78d1271009 graphics/libyuv: track libjpeg dependency
-- Found JPEG: /usr/local/lib/libjpeg.so (found version "80")
[...]
Error: /usr/local/bin/yuvconvert is linked to /usr/local/lib/libjpeg.so.8 from graphics/jpeg-turbo but it is not declared as a dependency
Warning: you need USES+=jpeg

PR:		267163
2023-05-07 05:18:26 +00:00

18 lines
614 B
Text

https://chromium.googlesource.com/libyuv/libyuv.git/+/c365da9c6c3a%5E!/
https://chromium.googlesource.com/libyuv/libyuv.git/+/f428a642e3d8%5E!/
--- CMakeLists.txt.orig 2021-10-26 08:34:37 UTC
+++ CMakeLists.txt
@@ -35,10 +35,10 @@ TARGET_LINK_LIBRARIES ( yuvconvert ${ly_lib_static} )
TARGET_LINK_LIBRARIES ( yuvconvert ${ly_lib_static} )
-INCLUDE ( FindJPEG )
+find_package ( JPEG )
if (JPEG_FOUND)
include_directories( ${JPEG_INCLUDE_DIR} )
- target_link_libraries( yuvconvert ${JPEG_LIBRARY} )
+ target_link_libraries( ${ly_lib_shared} ${JPEG_LIBRARY} )
add_definitions( -DHAVE_JPEG )
endif()