mirror of
https://git.freebsd.org/ports.git
synced 2025-05-02 11:36:40 -04:00
This port builds only the generic Z80 emulator and installs various CP/M-80 disk images. The images can be copied into user directories and updated from within the emulation of with the cpmtools programs. The emulation covers CP-NET and MP/M-80 and addition to CP/M-1.4, CP/M-2.2, and CP/M-3.0. The port could be extended to install the full hardware emulation of some classic S-100 bus computers from ALTAIR, IMSAI, and Cromemco (including working emulation of the front panels).
30 lines
638 B
Text
30 lines
638 B
Text
--- cpmsim/srctools/Makefile.orig 2021-01-06 16:07:39 UTC
|
|
+++ cpmsim/srctools/Makefile
|
|
@@ -1,19 +1,19 @@
|
|
#
|
|
# some places where the tools usually are installed
|
|
#
|
|
-INSTALLDIR=${HOME}/bin
|
|
+#INSTALLDIR=${HOME}/bin
|
|
#INSTALLDIR=/usr/local/bin
|
|
|
|
#CC = cc
|
|
-CC = gcc
|
|
+#CC = gcc
|
|
|
|
-CFLAGS= -O3 -Wall
|
|
+#CFLAGS= -O3 -Wall
|
|
|
|
-all: test mkdskimg bin2hex send receive ptp2bin
|
|
- @echo
|
|
- @echo "Done."
|
|
- @echo "Now run make install"
|
|
- @echo
|
|
+all: mkdskimg bin2hex send receive ptp2bin
|
|
+# @echo
|
|
+# @echo "Done."
|
|
+# @echo "Now run make install"
|
|
+# @echo
|
|
|
|
test:
|
|
@test -d ${INSTALLDIR} || (echo "${INSTALLDIR} doesn't exist, fix INSTALLDIR"; exit 1)
|