ports/databases/rrdtool/files/patch-bindings_Makefile.in
Tatsuki Makino 64bcfa1862 databases/rrdtool: Fix build with PYTHON option on
- Add py-setuptools build dependency to PYTHON option (Build PYTHON bindings)
  to fix build when this option is used
- Add harfbuzz lib depends to GRAPH option (Enable the rrdtool graph command)
- Use configure helper for EXAMPLES option
- Define LICENSE_FILE

PR:		265203
Reported by:	Sigi <freebsd-bt@beatsnet.com>
MFH:		2023Q1 (build fixes)
2023-01-04 20:35:48 +00:00

16 lines
651 B
Text

--- bindings/Makefile.in.orig 2022-03-14 14:29:39 UTC
+++ bindings/Makefile.in
@@ -727,11 +727,11 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
$(AM_V_GEN)test -f ${builddir}/perl-piped/Makefile \
&& ( cd ${builddir}/perl-piped \
- && $(MAKE) install ) \
+ && $(MAKE) pure_install ) \
|| true
$(AM_V_GEN)test -f ${builddir}/perl-shared/Makefile \
&& ( cd ${builddir}/perl-shared \
- && $(MAKE) install ) \
+ && $(MAKE) pure_install ) \
|| true
$(AM_V_GEN)test -f ${builddir}/ruby/Makefile \
&& ( cd ${builddir}/ruby \