ports/security/beidconnect/files/patch-linux_Makefile
Tijl Coosemans 909c172b80 security/beidconnect: New port, version 2.10
BeIDConnect is a browser extension to sign documents with a Belgian eID
card.
2024-03-23 12:28:22 +01:00

26 lines
1.2 KiB
Text

--- linux/Makefile.orig 2023-11-13 21:45:08 UTC
+++ linux/Makefile
@@ -1,16 +1,19 @@
+CFLAGS ?= -O2
+CXXFLAGS ?= -O2
PLDFLAGS = $(shell pkg-config --libs libpcsclite)
PCFLAGS = $(shell pkg-config --cflags libpcsclite)
+PREFIX ?= /usr
beidconnect: asn1.o BEIDCard.o CardFactory.o CardReader.o CertChainRequestHandler.o comm.o hash.o InfoRequestHandler.o log.o main.o native.o ReaderList.o Request.o RequestHandler.o SCard.o SignRequestHandler.o UserCertsRequestHandler.o util.o VersionRequestHandler.o VirtualCard.o VirtualReader.o x509Util.o crypto.o setup.o test.o IDRequestHandler.o
$(CXX) $^ $(PLDFLAGS) $(LDFLAGS) -o $@
%.o: ../common/%.cpp
- $(CXX) -c -O2 -std=gnu++11 $(CXXFLAGS) $(PCFLAGS) -fPIE -I../common -o $@ $<
+ $(CXX) -c -std=gnu++11 $(CXXFLAGS) $(PCFLAGS) -fPIE -I../common -o $@ $<
%.o: ../common/%.c
- $(CC) -c -O2 -std=gnu99 $(CFLAGS) $(PCFLAGS) -fPIE -I../common -o $@ $<
+ $(CC) -c -std=gnu99 $(CFLAGS) $(PCFLAGS) -fPIE -I../common -o $@ $<
install:
- install -d $(DESTDIR)/usr/bin
- install -m 755 beidconnect $(DESTDIR)/usr/bin/
+ install -d $(DESTDIR)$(PREFIX)/bin
+ install -m 755 beidconnect $(DESTDIR)$(PREFIX)/bin/
clean:
rm -f *.o beidconnect