mirror of
https://git.freebsd.org/ports.git
synced 2025-05-16 01:01:49 -04:00
* Add USES= compiler:c++17-lang * Remove USES= python:build * Add LICENSE_FILE * Fix install path of .pc file * Make some minor changes to port Makefile Changelog: https://github.com/libxmlplusplus/libxmlplusplus/releases/tag/5.2.0 PR: 279757 Approved by: portmgr (maintainer timeout, 2+ weeks)
20 lines
803 B
Text
20 lines
803 B
Text
--- meson.build.orig 2024-01-11 13:10:47 UTC
|
|
+++ meson.build
|
|
@@ -98,7 +98,7 @@ install_datadir = get_option('datadir')
|
|
install_includedir = get_option('includedir')
|
|
install_libdir = get_option('libdir')
|
|
install_datadir = get_option('datadir')
|
|
-install_pkgconfigdir = install_libdir / 'pkgconfig'
|
|
+install_pkgconfigdir = join_paths('libdata', 'pkgconfig')
|
|
|
|
# Dependencies.
|
|
# xmlxx_build_dep: Dependencies when building the libxml++ library.
|
|
@@ -370,7 +370,7 @@ xmlxxconfig_h_meson = files('libxml++config.h.meson')
|
|
)
|
|
|
|
xmlxxconfig_h_meson = files('libxml++config.h.meson')
|
|
-install_includeconfigdir = install_libdir / xmlxx_pcname / 'include'
|
|
+install_includeconfigdir = install_includedir / xmlxx_pcname / 'include'
|
|
configure_file(
|
|
input: xmlxxconfig_h_meson,
|
|
output: 'libxml++config.h',
|