ports/security/wpa_supplicant-devel/files/patch-wpa__supplicant_Makefile
Cy Schubert cdbd267d33 net/hostapd-devel, security/wpa_supplicant-devel
Add two new development ports tracking the latest w1.fi development.
WPA developement is hosted at git://w1.fi/hostap.git however ports
plumbing provides API access to github. Therefore I cloned/forked
hostap, renaming "origin" to "upstream," with a brand-new "origin"
located on github. In theory this will allow me to git pull from
git://w1.fi/hostap.git and push to my github repo.

This will coincide with base tracking more recent developent at w1.fi,
supporting WPA3.

Discussed with:		phillip@
2021-03-19 00:18:22 +00:00

17 lines
479 B
Text

--- wpa_supplicant/Makefile.orig 2015-03-15 17:30:39 UTC
+++ wpa_supplicant/Makefile
@@ -99,6 +99,14 @@ OBJS += ../src/utils/os_$(CONFIG_OS).o
OBJS_p += ../src/utils/os_$(CONFIG_OS).o
OBJS_c += ../src/utils/os_$(CONFIG_OS).o
+ifdef CONFIG_DRIVER_NDIS
+OBJS += ../src/utils/Packet32.o
+ifdef CONFIG_PRIVSEP
+OBJS += ../src/drivers/driver_ndis.o
+endif
+OBJS_priv += ../src/utils/Packet32.o
+endif
+
ifdef CONFIG_WPA_TRACE
CFLAGS += -DWPA_TRACE
OBJS += ../src/utils/trace.o