mirror of
https://git.freebsd.org/ports.git
synced 2025-05-17 01:23:12 -04:00
21 lines
569 B
Text
21 lines
569 B
Text
--- meson.build.orig 2023-03-08 16:41:32 UTC
|
|
+++ meson.build
|
|
@@ -4,6 +4,9 @@ threads = dependency('threads')
|
|
libevdev = dependency('libevdev')
|
|
libpam = meson.get_compiler('cpp').find_library('pam')
|
|
threads = dependency('threads')
|
|
+# On FreeBSD, libepoll-shim library is required for signalfd.h
|
|
+epoll_shim = dependency('epoll-shim', required : false)
|
|
+libintl = dependency('intl')
|
|
|
|
# Translations
|
|
subdir('po')
|
|
@@ -17,6 +20,8 @@ shared_library(
|
|
inih_cpp,
|
|
threads,
|
|
libevdev,
|
|
+ epoll_shim,
|
|
+ libintl,
|
|
],
|
|
install: true,
|
|
install_dir: '/lib/security',
|