mirror of
https://git.freebsd.org/ports.git
synced 2025-05-18 18:13:12 -04:00
* Process to fix paths in script and configuration files are simplified. * Now man page of logcheck is generated from DocBook SGML source file by using textproc/docbook-to-man. * Sort pkg-plist. * Add forgotten files/patch-etc_logcheck.logfiles. * Update files/patch-etc_logcheck.conf * Move backup file cleaning up from post-patch to do-build so 'make makepatch' works as expected. PR: 220609 Submitted by: yasu@utahime.org (maintainer)
11 lines
464 B
Text
11 lines
464 B
Text
--- src/logtail2.orig 2017-07-11 17:32:13 UTC
|
|
+++ src/logtail2
|
|
@@ -109,7 +109,7 @@ sub determine_rotated_logfile {
|
|
# function with dateext magic added.
|
|
|
|
#print "determine_rotated_logfile $filename $inode\n";
|
|
- for my $codefile (glob("/usr/share/logtail/detectrotate/*.dtr")) {
|
|
+ for my $codefile (glob("%%DATADIR%%/detectrotate/*.dtr")) {
|
|
my $func = do $codefile;
|
|
if (!$func) {
|
|
print STDERR "cannot compile $codefile: $!";
|