ports/multimedia/libde265/files/patch-disable-tools
Daniel Engberg c9445b18bf multimedia/libde265: Update to 1.0.8
- Use upstream release archive as recommended by Porters Handbook
  (see USE_GITHUB section)
- Backport upstream commits 900772c3e9ee1e106b93283fd8e7633d52899e40 ,
  7d5aeb5f11531de33f5b7ae0e768ffc50da4facb ,
  dbff9077462899fc8e3b39907d43c2a6ad54e9f3 ,
  a3f1c6a0dea2b0d4a531255ad06ed40cdb184d25 and
  4c0fe2c149c68ece57fde4cb11e05b5fb572da4b for various bug fixes
- Package dec265 utility, also rename it as libde265-dec265 to match
  Debian's repository
- Import patches from Debian to only expose public API and disable
  tools that don't build without internal API exposed.

References:

900772c3e9
7d5aeb5f11
dbff907746
a3f1c6a0de
4c0fe2c149
https://salsa.debian.org/multimedia-team/libde265/-/blob/master/debian/patches/only_export_decoder_api.patch
https://salsa.debian.org/multimedia-team/libde265/-/blob/master/debian/patches/disable_tools.patch

Patch initially submitted by vishwin

PR:		251442
Reported by:	vishwin
Approved by:	kwm (maintainer timeout, 14+ months)
2022-02-26 13:18:28 +01:00

41 lines
924 B
Text

Description: Disable building of some internal tools that no longer link
because internal symbols are no longer exported.
Author: Joachim Bauch <bauch@struktur.de>
--- dec265/Makefile.am
+++ dec265/Makefile.am
@@ -1,5 +1,5 @@
-bin_PROGRAMS = dec265 hdrcopy
+bin_PROGRAMS = dec265
AM_CPPFLAGS = -I$(top_srcdir)/libde265 -I$(top_srcdir)
@@ -9,12 +9,6 @@
dec265_LDADD = ../libde265/libde265.la -lstdc++
dec265_SOURCES = dec265.cc
-hdrcopy_DEPENDENCIES = ../libde265/libde265.la
-hdrcopy_CXXFLAGS =
-hdrcopy_LDFLAGS =
-hdrcopy_LDADD = ../libde265/libde265.la -lstdc++
-hdrcopy_SOURCES = hdrcopy.cc
-
if HAVE_VIDEOGFX
dec265_CXXFLAGS += $(VIDEOGFX_CFLAGS)
dec265_LDFLAGS += $(VIDEOGFX_LIBS)
--- Makefile.am
+++ Makefile.am
@@ -8,13 +8,6 @@
SUBDIRS+=dec265
endif
-if ENABLE_ENCODER
-SUBDIRS+=enc265
-endif
-
-SUBDIRS+=tools
-SUBDIRS+=acceleration-speed
-
if ENABLE_SHERLOCK265
SUBDIRS+=sherlock265
endif