mirror of
https://git.freebsd.org/ports.git
synced 2025-05-16 17:21:49 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
39 lines
1.5 KiB
Text
39 lines
1.5 KiB
Text
--- meson.build.orig 2024-08-21 11:25:15 UTC
|
|
+++ meson.build
|
|
@@ -17,6 +17,8 @@ gst_version_is_dev = gst_version_minor % 2 == 1 and gs
|
|
gst_version_is_stable = gst_version_minor.is_even()
|
|
gst_version_is_dev = gst_version_minor % 2 == 1 and gst_version_micro < 90
|
|
|
|
+build_gstgl = false
|
|
+
|
|
host_system = host_machine.system()
|
|
|
|
have_cxx = add_languages('cpp', native: false, required: false)
|
|
@@ -293,8 +295,10 @@ core_conf.set_quoted('DEFAULT_VIDEOSINK', 'autovideosi
|
|
|
|
# FIXME: These should be configure options
|
|
core_conf.set_quoted('DEFAULT_VIDEOSINK', 'autovideosink')
|
|
-core_conf.set_quoted('DEFAULT_AUDIOSINK', 'autoaudiosink')
|
|
|
|
+core_conf.set_quoted('DEFAULT_AUDIOSINK', get_option('defaultaudiosink'))
|
|
+core_conf.set_quoted('DEFAULT_AUDIOSRC', get_option('defaultaudiosrc'))
|
|
+
|
|
# Set whether the audioresampling method should be detected at runtime
|
|
core_conf.set('AUDIORESAMPLE_FORMAT_' + get_option('audioresample_format').to_upper(), true)
|
|
|
|
@@ -505,6 +509,7 @@ pkgconfig_plugins_base_libs_variables = [
|
|
'libraries=' + ' '.join(base_libraries),
|
|
]
|
|
|
|
+if get_option('pkgconfig').enabled()
|
|
pkgconfig.generate(
|
|
libraries : [gst_dep],
|
|
variables : pkgconfig_variables + pkgconfig_plugins_base_libs_variables,
|
|
@@ -518,6 +523,7 @@ run_command(meson_pkg_config_file_fixup_script,
|
|
run_command(meson_pkg_config_file_fixup_script,
|
|
'gstreamer-plugins-base-1.0', 'libraries',
|
|
check: true)
|
|
+endif
|
|
|
|
if have_orcc
|
|
update_orc_dist_files = find_program('scripts/update-orc-dist-files.py')
|