mirror of
https://git.freebsd.org/ports.git
synced 2025-05-16 01:01:49 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
22 lines
780 B
Text
22 lines
780 B
Text
--- ext/gl/meson.build.orig 2024-08-21 11:25:15 UTC
|
|
+++ ext/gl/meson.build
|
|
@@ -114,10 +114,6 @@ endif
|
|
optional_deps += bcm_host_dep
|
|
endif
|
|
|
|
-if egl_dep.found() and cc.has_header('libdrm/drm_fourcc.h')
|
|
- optional_deps += allocators_dep
|
|
-endif
|
|
-
|
|
if ['darwin', 'ios'].contains(host_system)
|
|
if not have_objc
|
|
error('No ObjC compiler found')
|
|
@@ -144,7 +140,7 @@ gstopengl = library('gstopengl',
|
|
objc_args : gst_plugins_base_args + gl_objc_args + extra_c_args,
|
|
link_args : noseh_link_args,
|
|
include_directories : [configinc],
|
|
- dependencies : [gstgl_dep, video_dep,
|
|
+ dependencies : [gstgl_dep, dependency('gstreamer-video-1.0'),
|
|
gst_base_dep, gst_controller_dep, libm] + optional_deps,
|
|
install : true,
|
|
install_dir : plugins_install_dir)
|