ports/multimedia/ffmpeg4/files/patch-libswscale_ppc_yuv2rgb__altivec.c
Jan Beich f0dadc529f multimedia/ffmpeg: fork 4.* into a pinned port
Mainly for leaf consumers: applications but not plugins or libraries.
Otherwise, indirectly mixing different versions of ffmpeg libraries at
runtime can lead to crashes.

To use simply add the following before <bsd.port.mk> or <bsd.port.pre.mk>

  .include "${.CURDIR:H:H}/multimedia/ffmpeg4/override.mk"

PR:		261302
Inspired by:	c717faa5c7
2023-03-17 20:59:23 +00:00

15 lines
708 B
C

Error:
libswscale/ppc/yuv2rgb_altivec.c:288:36: error: redeclaration of 'vec_xl' must have the 'overloadable' attribute
static inline vector unsigned char vec_xl(signed long long offset, const ubyte *addr)
--- libswscale/ppc/yuv2rgb_altivec.c.orig 2021-04-08 21:28:40 UTC
+++ libswscale/ppc/yuv2rgb_altivec.c
@@ -284,7 +284,7 @@ static inline void cvtyuvtoRGB(SwsContext *c, vector s
* ------------------------------------------------------------------------------
*/
-#if !HAVE_VSX
+#if !HAVE_VSX && !defined(__clang__)
static inline vector unsigned char vec_xl(signed long long offset, const ubyte *addr)
{
const vector unsigned char *v_addr = (const vector unsigned char *) (addr + offset);