mirror of
https://git.freebsd.org/ports.git
synced 2025-05-17 01:23:12 -04:00
Mainly for leaf consumers: applications but not plugins or libraries.
Otherwise, indirectly mixing different versions of ffmpeg libraries at
runtime can lead to crashes.
To use simply add the following before <bsd.port.mk> or <bsd.port.pre.mk>
.include "${.CURDIR:H:H}/multimedia/ffmpeg4/override.mk"
PR: 261302
Inspired by: c717faa5c7
11 lines
450 B
C
11 lines
450 B
C
--- libavutil/x86/asm.h.orig 2015-06-19 20:44:54 UTC
|
|
+++ libavutil/x86/asm.h
|
|
@@ -71,7 +71,7 @@ typedef int32_t x86_reg;
|
|
typedef int x86_reg;
|
|
#endif
|
|
|
|
-#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE))
|
|
+#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE && !defined(__clang__)))
|
|
#define HAVE_6REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE || HAVE_EBP_AVAILABLE))
|
|
|
|
#if ARCH_X86_64 && defined(PIC)
|