mirror of
https://git.freebsd.org/ports.git
synced 2025-05-18 10:03:10 -04:00
- Switch to DISTVERSION - Define LICENSE_FILE - Use autoreconf as workaround to fix build (not needed in <= 3.1.3) - Put most SED commands in patches - Comment patches about what they doing - Port uses USES=jpeg and not openjpeg* (at the moment) - Take maintainership ChangeLog: https://sourceforge.net/projects/sf-xpaint/files/sf-xpaint/
25 lines
673 B
Text
25 lines
673 B
Text
Respect compiler and fix DESTDIR path.
|
|
|
|
--- vxp2ps/Makefile.orig 2021-01-19 08:35:54 UTC
|
|
+++ vxp2ps/Makefile
|
|
@@ -3,16 +3,16 @@ vxp2ps: vxp2ps.c
|
|
all: vxp2ps vxp2tex vxp2dkw
|
|
|
|
vxp2ps: vxp2ps.c
|
|
- gcc vxp2ps.c -o vxp2ps -lm $(CFLAGSEXTRA)
|
|
+ $(CC) $(CFLAGS) vxp2ps.c -o vxp2ps -lm $(CFLAGSEXTRA)
|
|
|
|
vxp2tex: vxp2tex.c
|
|
- gcc vxp2tex.c -o vxp2tex -lm
|
|
+ $(CC) $(CFLAGS) vxp2tex.c -o vxp2tex -lm
|
|
|
|
vxp2dkw: vxp2dkw.c
|
|
- gcc vxp2dkw.c -o vxp2dkw -lm
|
|
+ $(CC) $(CFLAGS) vxp2dkw.c -o vxp2dkw -lm
|
|
|
|
install: all
|
|
- install -c -s vxp2ps vxp2tex vxp2dkw "$(DESTDIR)"/usr/bin
|
|
+ install -c -s vxp2ps vxp2tex vxp2dkw $(DESTDIR)$(PREFIX)/bin
|
|
|
|
clean:
|
|
rm -f core *~ vxp2ps vxp2tex vxp2dkw
|