ports/graphics/epsonscan2/files/patch-src_Controller_CMakeLists.txt
Rainer Hurling 27df5bce08 graphics/epsonscan2: Add new port for Epson Scanners
This is a port of the Seiko/Epson Epsonscan2 scanner engine and GUI[1].

It provides a complete alternative to sane/xsane with its own scanner engine and GUI.
It also provides a sane back-end library (libsane-epsonscan2.so) so that it works with the sane package.

There are two parts to this port:
  - graphics/epsonscan2 - the main scanner engine and GUI that
    works with (most) USB scanners
  - graphics/epsonscan2-non-free-plugin - support for Epson's
    Linux binary that adds network access to scanners and
    usb access to some particular scanners

Please read the file %%PREFIX%%/lib/epsonscan2/Read_me.FreeBSD for notes on how to set this up and use it.

[1] https://download.ebz.epson.net/man/linux/epsonscan2_e.html

PR:		261891
Reviewed by:	(partly) Tatsuki Makino <tatsuki_makino@hotmail.com>, diizzy@
2022-04-03 10:44:09 +02:00

11 lines
309 B
Text

--- src/Controller/CMakeLists.txt.orig 2021-11-25 00:56:54 UTC
+++ src/Controller/CMakeLists.txt
@@ -171,7 +171,7 @@ target_link_libraries( epsonscan2
dl
commonutility
${Boost_LIBRARIES}
- usb-1.0
+ ${usb_LIBRARY}
)
install(TARGETS epsonscan2 DESTINATION ${EPSON_INSTALL_ROOT}${EPSON_INSTALL_PATH})