ports/devel/cvs/files/patch-cvs__lib_Makefile
Xin LI 73420d98b2 devel/cvs: remove libgnuregex dependency.
The only usage of regular expression in cvs was in import.c, and for
that particular usage, no GNU extension was used; with the removal of
libgnuregex, we could just drop the dependency and use the base system
regex(3) instead.

This fixes build on -CURRENT.

PR:		252248
Approved by:	maintainer
MFH:		2021Q1
2021-01-03 19:21:21 +00:00

22 lines
623 B
Text

--- ../cvs-build/lib/Makefile.orig 2012-09-05 19:19:41.000000000 -0700
+++ ../cvs-build/lib/Makefile 2021-01-02 17:10:09.173277000 -0800
@@ -11,9 +11,7 @@
LIB= cvs
INTERNALLIB=
-# gnu must be before lib to pick correct regex.h
-CFLAGS+= -I. -I${CVSDIR}/src -I/usr/include/gnu \
- -I${CVSDIR}/lib
+CFLAGS+= -I. -I${CVSDIR}/src -I${CVSDIR}/lib
CFLAGS+= -DHAVE_CONFIG_H
YFLAGS=
CLEANFILES+= config.h
@@ -23,7 +21,7 @@
CVS_TMPDIR_DFLT?= /tmp
SRCS= config.h argmatch.c getdate.y getline.c \
- getopt.c getopt1.c savecwd.c \
+ getopt.c getopt1.c regex.c savecwd.c \
sighandle.c stripslash.c \
xgetwd.c yesno.c