ports/devel/calibrator/files/patch-Makefile
Brooks Davis f2ab442843 Fix build with src r354909 applied.
The referenced change made NO_INSTALLLIB, NO_MAN, and NO_PROFILE into
errors causing these ports that declare them and use the FreeBSD make
infrastructure as part of their build to fail.

When the offending variables occur in a BSD Makefile, NO_MAN becomes
MAN= and NO_INSTALLLIB and NO_PROFILE become MK_INSTALLLIB=no and
MK_PROFILE=no respectively.  When declared in the environment they
become WITHOUT_<FOO>.
2019-11-25 23:25:52 +00:00

11 lines
207 B
Text

--- Makefile.orig Mon Oct 13 11:14:02 2003
+++ Makefile Mon Oct 13 11:16:20 2003
@@ -0,0 +1,8 @@
+PROG= calibrator
+SRCS= calibrator.c
+MAN=
+
+CFLAGS+= -D_ANSI_SOURCE
+LDADD+= -lm
+
+.include <bsd.prog.mk>