ports/security/sudosh3/files/patch-src::Makefile.in
Mikhail Teterin a4d51a600a Refactor the replay code to fix the reported vulnerability -- simply use mmap()
instead of a buffer.

Bump PORTREVISION.

While here, fix warnings -- well enough for gcc48 to be happy with ``-Wall -W''.

Approved by:	maintainer timeout (since February).
2013-05-21 16:29:19 +00:00

85 lines
3.5 KiB
Text

--- src/Makefile.in 2008-02-22 16:11:02.000000000 -0500
+++ src/Makefile.in 2013-02-12 16:16:50.000000000 -0500
@@ -51,11 +51,11 @@
string.$(OBJEXT) util.$(OBJEXT)
sudosh_OBJECTS = $(am_sudosh_OBJECTS)
sudosh_LDADD = $(LDADD)
-am_sudosh_replay_OBJECTS = replay.$(OBJEXT) getopt.$(OBJEXT) \
+am_sudosh_replay_OBJECTS = replay.$(OBJEXT) \
string.$(OBJEXT) parse.$(OBJEXT) util.$(OBJEXT)
sudosh_replay_OBJECTS = $(am_sudosh_replay_OBJECTS)
sudosh_replay_LDADD = $(LDADD)
-DEFAULT_INCLUDES = -I. -I$(top_builddir)@am__isrc@
+DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
@@ -165,10 +165,11 @@
target_cpu = @target_cpu@
target_os = @target_os@
target_vendor = @target_vendor@
+top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-sudosh_SOURCES = sudosh.c rand.c parse.c string.c getopt.h struct.h super.h util.c
-sudosh_replay_SOURCES = replay.c getopt.c getopt.h string.c parse.c util.c
+sudosh_SOURCES = sudosh.c rand.c parse.c string.c struct.h super.h util.c
+sudosh_replay_SOURCES = replay.c string.c parse.c util.c
EXTRA_DIST = sudosh.conf
all: all-am
@@ -241,7 +242,6 @@
distclean-compile:
-rm -f *.tab.c
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getopt.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/parse.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rand.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/replay.Po@am__quote@
@@ -268,8 +268,8 @@
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonemtpy = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
mkid -fID $$unique
tags: TAGS
@@ -281,8 +281,8 @@
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
test -n "$$unique" || unique=$$empty_fix; \
$(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
@@ -292,13 +292,12 @@
CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
$(TAGS_FILES) $(LISP)
tags=; \
- here=`pwd`; \
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
test -z "$(CTAGS_ARGS)$$tags$$unique" \
|| $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
$$tags $$unique
@@ -442,7 +441,7 @@
install-sudosh.conf:
test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
- test -f $(sysconfdir)/sudosh.conf || $(INSTALL) -o 0 -g 0 -m 0444 '$(srcdir)/sudosh.conf' '$(sysconfdir)/sudosh.conf'
+ $(INSTALL) -o 0 -g 0 -m 0444 '$(srcdir)/sudosh.conf' '$(sysconfdir)/sudosh.conf.sample'
install: install-am install-sudosh.conf
# Tell versions [3.59,3.63) of GNU make to not export all variables.