mirror of
https://git.freebsd.org/ports.git
synced 2025-05-20 19:13:27 -04:00
Sync system libvpx with bundled libvpx in Firefox 40 in order to fix vulnerabilities in the former. While here fix other issues: - Add powerpc targets removed by upstream - Add sparc64 support [1] - Improve gcc42 workaround [2] - Strip binaries as reported by stage-qa - Drop unused -no-integrated-as hack for Clang Changes: https://chromium.googlesource.com/webm/libvpx/+log/v1.4.0..e67d45d ACC report: https://people.freebsd.org/~jbeich/compat_reports/libvpx/1.4.0_to_1.4.0.488/compat_report.html PR: 202270 PR: 186394 [1] (based on) PR: 189136 [2] Exp-run by: antoine Approved by: ashish (maintainer) MFH: 2015Q3 Security: http://www.vuxml.org/freebsd/34e60332-2448-4ed6-93f0-12713749f250.html
13 lines
328 B
Text
13 lines
328 B
Text
--- build/make/Makefile.orig
|
|
+++ build/make/Makefile
|
|
@@ -230,8 +230,8 @@
|
|
define install_map_template
|
|
$(DIST_DIR)/$(1): $(2)
|
|
$(if $(quiet),@echo " [INSTALL] $$@")
|
|
- $(qexec)mkdir -p $$(dir $$@)
|
|
- $(qexec)cp -p $$< $$@
|
|
+ $(qexec)install -d $$(dir $$@)
|
|
+ $(qexec)install -p $$< $$(dir $$@)
|
|
endef
|
|
|
|
define archive_template
|