mirror of
https://git.freebsd.org/ports.git
synced 2025-05-20 02:53:10 -04:00
Release notes: https://www.elastic.co/guide/en/beats/libbeat/7.16/release-notes-7.16.2.html
26 lines
1.5 KiB
Text
26 lines
1.5 KiB
Text
--- libbeat/scripts/Makefile.orig 2021-12-17 15:54:41 UTC
|
|
+++ libbeat/scripts/Makefile
|
|
@@ -42,7 +42,7 @@ GOFILES = $(shell find . -type f -name '*.go' 2>/dev/n
|
|
GOFILES_NOVENDOR = $(shell find . -type f -name '*.go' -not -path "*/vendor/*" 2>/dev/null)
|
|
GOFILES_ALL = $(GOFILES) $(shell find $(ES_BEATS) -type f -name '*.go' 2>/dev/null)
|
|
GOPACKAGES_STRESSTESTS=$(shell find . -name '*.go' 2>/dev/null | xargs grep -l '\+build.*stresstest' | xargs -n1 dirname | uniq)
|
|
-SHELL=bash
|
|
+SHELL=sh
|
|
ES_HOST?=elasticsearch
|
|
ES_PORT?=9200
|
|
ES_USER?=beats
|
|
@@ -346,12 +346,12 @@ ifndef EXCLUDE_COMMON_UPDATE_TARGET
|
|
update: python-env fields collect config ## @build Update expects the most recent version of libbeat in the GOPATH
|
|
@echo "Updating generated files for ${BEAT_NAME}"
|
|
|
|
-ifneq ($(shell [[ $(BEAT_NAME) == libbeat || $(BEAT_NAME) == metricbeat ]] && echo true ),true)
|
|
+ifneq ($(shell [[ $(BEAT_NAME) = libbeat || $(BEAT_NAME) = metricbeat ]] && echo true ),true)
|
|
mkdir -p include
|
|
go run ${INSTALL_FLAG} ${ES_BEATS}/dev-tools/cmd/asset/asset.go -license $(LICENSE) -pkg include -in fields.yml -out include/fields.go $(BEAT_NAME)
|
|
endif
|
|
|
|
-ifneq ($(shell [[ $(BEAT_NAME) == libbeat || $(BEAT_NAME) == metricbeat ]] && echo true ),true)
|
|
+ifneq ($(shell [[ $(BEAT_NAME) = libbeat || $(BEAT_NAME) = metricbeat ]] && echo true ),true)
|
|
@# Update docs
|
|
@mkdir -p docs
|
|
@${PYTHON_ENV_EXE} ${ES_BEATS}/libbeat/scripts/generate_fields_docs.py $(PWD)/fields.yml ${BEAT_TITLE} ${ES_BEATS}
|