mirror of
https://git.freebsd.org/ports.git
synced 2025-05-18 18:13:12 -04:00
PR: 265468 Bugs Fixed: - InnoDB: A TRUNCATE TABLE operation failed to remove data dictionary entries for columns that were dropped using ALGORITHM=INSTANT. - InnoDB: An incorrect nullable column calculation on tables with instantly added columns caused data to be interpreted incorrectly - InnoDB: The read_2_bytes() function in the InnoDB sources, which reads bytes from the log buffer, returned a null pointer. - Replication: The COUNT_TRANSACTIONS_REMOTE_IN_APPLIER_QUEUE column in the Performance Schema table replication_group_member_stats could persistently show transactions related to view change events (View_change_log_event) that had already been applied. These events are queued in the Group Replication applier channel but applied in the Group Replication recovery channel, causing a race condition that could result in the counter decrement being lost. The increment of the count now takes place at a more suitable point, and the counter for COUNT_TRANSACTIONS_REMOTE_IN_APPLIER_QUEUE is also now set to zero when the applier is not busy. - Debug MySQL binaries can now be built using -0g and -fno-inline. See full Changelog here: https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-30.html Sponsored by: Netzkommune GmbH
95 lines
2.6 KiB
Text
95 lines
2.6 KiB
Text
--- CMakeLists.txt.orig 2022-07-06 21:36:34 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -1819,7 +1819,7 @@ IF(LINUX AND KNOWN_CUSTOM_LIBRARIES)
|
|
ENDIF()
|
|
|
|
IF(WITH_AUTHENTICATION_LDAP)
|
|
- IF(LINUX AND KNOWN_CUSTOM_LIBRARIES)
|
|
+ IF(LINUX OR FREEBSD AND KNOWN_CUSTOM_LIBRARIES)
|
|
# LDAP / SASL / KERBEROS / SSL must all be "system" or "custom", not a mix.
|
|
IF(WITH_LDAP STREQUAL "system" OR
|
|
WITH_SASL STREQUAL "system" OR
|
|
@@ -1868,6 +1868,7 @@ IF(WITH_AUTHENTICATION_KERBEROS)
|
|
ENDIF()
|
|
ENDIF()
|
|
|
|
+IF(NOT WITHOUT_TOOLS)
|
|
# Add system/bundled editline.
|
|
MYSQL_CHECK_EDITLINE()
|
|
SET(EDITLINE_WARN_GIVEN)
|
|
@@ -1878,7 +1879,9 @@ IF(EDITLINE_WARN_GIVEN)
|
|
"You can use -DWITH_EDITLINE=bundled instead."
|
|
)
|
|
ENDIF()
|
|
+ENDIF(NOT WITHOUT_TOOLS)
|
|
|
|
+IF(NOT WITHOUT_SERVER)
|
|
# Add libevent
|
|
MYSQL_CHECK_LIBEVENT()
|
|
SET(LIBEVENT_WARN_GIVEN)
|
|
@@ -1889,6 +1892,7 @@ IF(LIBEVENT_WARN_GIVEN)
|
|
"You can use -DWITH_LIBEVENT=bundled instead."
|
|
)
|
|
ENDIF()
|
|
+ENDIF(NOT WITHOUT_SERVER)
|
|
|
|
# Add lz4 library
|
|
MYSQL_CHECK_LZ4()
|
|
@@ -2142,7 +2146,9 @@ ADD_CUSTOM_TARGET(clang_tidy_prerequisites)
|
|
ADD_DEPENDENCIES(clang_tidy_prerequisites protobuf_generated_all)
|
|
ADD_DEPENDENCIES(clang_tidy_prerequisites GenError)
|
|
|
|
-ADD_SUBDIRECTORY(include)
|
|
+IF(NOT WITHOUT_CLIENTLIBS)
|
|
+ ADD_SUBDIRECTORY(include)
|
|
+ENDIF(NOT WITHOUT_CLIENTLIBS)
|
|
ADD_SUBDIRECTORY(strings)
|
|
ADD_SUBDIRECTORY(vio)
|
|
ADD_SUBDIRECTORY(mysys)
|
|
@@ -2187,12 +2193,15 @@ IF(WITH_UNIT_TESTS)
|
|
ADD_SUBDIRECTORY(unittest/mytap/t)
|
|
ENDIF()
|
|
|
|
-ADD_SUBDIRECTORY(client)
|
|
+IF(NOT WITHOUT_TOOLS)
|
|
+ ADD_SUBDIRECTORY(client)
|
|
+ENDIF(NOT WITHOUT_TOOLS)
|
|
+
|
|
ADD_SUBDIRECTORY(utilities)
|
|
-ADD_SUBDIRECTORY(share)
|
|
ADD_SUBDIRECTORY(libservices)
|
|
|
|
IF(NOT WITHOUT_SERVER)
|
|
+ ADD_SUBDIRECTORY(share)
|
|
ADD_SUBDIRECTORY(testclients)
|
|
ADD_SUBDIRECTORY(sql)
|
|
ENDIF()
|
|
@@ -2247,11 +2256,11 @@ ENDIF()
|
|
# scripts/mysql_config depends on client and server targets loaded above.
|
|
# It is referenced by some of the directories below, so we insert it here.
|
|
ADD_SUBDIRECTORY(scripts)
|
|
+ADD_SUBDIRECTORY(support-files)
|
|
|
|
IF(NOT WITHOUT_SERVER)
|
|
ADD_SUBDIRECTORY(mysql-test)
|
|
ADD_SUBDIRECTORY(mysql-test/lib/My/SafeProcess)
|
|
- ADD_SUBDIRECTORY(support-files)
|
|
IF(WITH_INTERNAL)
|
|
ADD_SUBDIRECTORY(internal)
|
|
ENDIF()
|
|
@@ -2361,6 +2370,7 @@ IF(PACK_SEPARATE_COMPONENTS)
|
|
SET(CPACK_COMPONENTS_GROUPING IGNORE)
|
|
ENDIF()
|
|
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
INSTALL(FILES
|
|
Docs/mysql.info
|
|
@@ -2395,6 +2405,7 @@ IF(NOT INSTALL_LAYOUT MATCHES "RPM")
|
|
PATTERN "sp-imp-spec.txt" EXCLUDE
|
|
PATTERN "README.build" EXCLUDE
|
|
)
|
|
+ENDIF()
|
|
ENDIF()
|
|
|
|
# Now that we're done with all ADD_SUBDIRECTORY and thus all feature tests,
|