ports/lang/micropython/files/patch-mpy-cross_Makefile
Kai Knoblich 31d9698334 lang/micropython: Update to 1.17
* Switch to GCC because building with Clang leads to a broken
  "mpy-cross" binary, which segfaults if issued with several parameters
  during build.

* REINPLACE_CMD should not be used to replace static content, hence
  convert those occurrences into patches.

* Also update pkg-descr and sort variables a bit according to the PHB.

Reviewed by:	decke (earlier revision)
Approved by:	kai (python, maintainer)
Differential Revision:	https://reviews.freebsd.org/D31855
2021-09-09 11:10:17 +02:00

26 lines
777 B
Text

* Avoid making all warnings into errors
* Extra optimizations via COPT should be overwritable
--- mpy-cross/Makefile.orig 2021-09-01 14:07:13 UTC
+++ mpy-cross/Makefile
@@ -17,7 +17,7 @@ INC += -I$(BUILD)
INC += -I$(TOP)
# compiler settings
-CWARN = -Wall -Werror
+CWARN = -Wall
CWARN += -Wextra -Wno-unused-parameter -Wpointer-arith
CFLAGS = $(INC) $(CWARN) -std=gnu99 $(CFLAGS_MOD) $(COPT) $(CFLAGS_EXTRA)
CFLAGS += -fdata-sections -ffunction-sections -fno-asynchronous-unwind-tables
@@ -25,9 +25,9 @@ CFLAGS += -fdata-sections -ffunction-sections -fno-asy
# Debugging/Optimization
ifdef DEBUG
CFLAGS += -g
-COPT = -O0
+COPT ?= -O0
else
-COPT = -Os #-DNDEBUG
+COPT ?= -Os #-DNDEBUG
endif
# On OSX, 'gcc' is a symlink to clang unless a real gcc is installed.