mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 18:16:48 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
62 lines
1.9 KiB
Text
62 lines
1.9 KiB
Text
--- cargo-crates/libc-0.2.69/src/unix/bsd/freebsdlike/freebsd/mod.rs.orig 2020-03-17 20:35:43 UTC
|
|
+++ cargo-crates/libc-0.2.69/src/unix/bsd/freebsdlike/freebsd/mod.rs
|
|
@@ -1486,6 +1486,9 @@ cfg_if! {
|
|
} else if #[cfg(target_arch = "powerpc64")] {
|
|
mod powerpc64;
|
|
pub use self::powerpc64::*;
|
|
+ } else if #[cfg(target_arch = "powerpc")] {
|
|
+ mod powerpc;
|
|
+ pub use self::powerpc::*;
|
|
} else {
|
|
// Unknown target_arch
|
|
}
|
|
--- cargo-crates/libc-0.2.69/src/unix/bsd/freebsdlike/freebsd/powerpc.rs.orig 2021-06-23 22:40:24 UTC
|
|
+++ cargo-crates/libc-0.2.69/src/unix/bsd/freebsdlike/freebsd/powerpc.rs
|
|
@@ -0,0 +1,47 @@
|
|
+pub type c_char = u8;
|
|
+pub type c_long = i32;
|
|
+pub type c_ulong = u32;
|
|
+pub type wchar_t = i32;
|
|
+pub type time_t = i64;
|
|
+pub type suseconds_t = i32;
|
|
+pub type register_t = i32;
|
|
+
|
|
+s! {
|
|
+ pub struct stat {
|
|
+ pub st_dev: ::dev_t,
|
|
+ pub st_ino: ::ino_t,
|
|
+ pub st_mode: ::mode_t,
|
|
+ pub st_nlink: ::nlink_t,
|
|
+ pub st_uid: ::uid_t,
|
|
+ pub st_gid: ::gid_t,
|
|
+ pub st_rdev: ::dev_t,
|
|
+ pub st_atime: ::time_t,
|
|
+ pub st_atime_nsec: ::c_long,
|
|
+ pub st_mtime: ::time_t,
|
|
+ pub st_mtime_nsec: ::c_long,
|
|
+ pub st_ctime: ::time_t,
|
|
+ pub st_ctime_nsec: ::c_long,
|
|
+ pub st_size: ::off_t,
|
|
+ pub st_blocks: ::blkcnt_t,
|
|
+ pub st_blksize: ::blksize_t,
|
|
+ pub st_flags: ::fflags_t,
|
|
+ pub st_gen: u32,
|
|
+ pub st_lspare: i32,
|
|
+ pub st_birthtime: ::time_t,
|
|
+ pub st_birthtime_nsec: ::c_long,
|
|
+ }
|
|
+}
|
|
+
|
|
+// should be pub(crate), but that requires Rust 1.18.0
|
|
+cfg_if! {
|
|
+ if #[cfg(libc_const_size_of)] {
|
|
+ #[doc(hidden)]
|
|
+ pub const _ALIGNBYTES: usize = ::mem::size_of::<::c_int>() - 1;
|
|
+ } else {
|
|
+ #[doc(hidden)]
|
|
+ pub const _ALIGNBYTES: usize = 4 - 1;
|
|
+ }
|
|
+}
|
|
+
|
|
+pub const MAP_32BIT: ::c_int = 0x00080000;
|
|
+pub const MINSIGSTKSZ: ::size_t = 2048; // 512 * 4
|