ports/graphics/opengv/files/extra-patch-CMakeLists.txt
Mark Linimon 6521bed65e Fix build on non-x86 architectures by conditionally turning off
-march=native.

Approved by:	portmgr (tier-2 blanket)
2019-04-03 04:33:35 +00:00

11 lines
421 B
Text

--- CMakeLists.txt.orig 2018-10-25 03:22:02 UTC
+++ CMakeLists.txt
@@ -35,8 +35,6 @@ ELSE()
ELSEIF (CMAKE_SYSTEM_PROCESSOR MATCHES
"(arm)|(ARM)|(armhf)|(ARMHF)|(armel)|(ARMEL)")
add_definitions (-march=armv7-a)
- ELSE ()
- add_definitions (-march=native) #TODO use correct c++11 def once everybody has moved to gcc 4.7 # for now I even removed std=gnu++0x
ENDIF()
add_definitions (
-O3