ports/cad/openvsp/files/patch-src_util_CMakeLists.txt
Fernando Apesteguía fb8a498ae4 cad/openvsp: update to 3.37.2
https://github.com/OpenVSP/OpenVSP/releases/tag/OpenVSP_3.37.2

3.37.1:

This version changes a compiler flag that makes a new dependency build properly
on Windows. This in turn fixes CFDMesh and FEAMesh on Windows.  Without this
change, 3.37.0 will quickly crash if you try to use either mesher. This won’t
change anything for non-windows users.

3.37.2 contains bugfixes

For now, use bundled fltk since the port uses a newer version than the one in
ports.
2024-03-26 19:36:30 +01:00

19 lines
423 B
Text

--- src/util/CMakeLists.txt.orig 2024-03-22 17:20:53 UTC
+++ src/util/CMakeLists.txt
@@ -21,6 +21,10 @@ INCLUDE_DIRECTORIES(
${PCGCPP_INCLUDE_DIR}
)
+set(CMAKE_THREAD_PREFER_PTHREAD TRUE)
+set(THREADS_PREFER_PTHREAD_FLAG TRUE)
+find_package(Threads REQUIRED)
+
ADD_LIBRARY(util
BndBox.cpp
CADutil.cpp
@@ -82,3 +86,5 @@ XferSurf.h
WriteMatlab.h
XferSurf.h
)
+
+target_link_libraries(util Threads::Threads)