mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
ChangeLog: https://github.com/certbot/certbot/blob/v3.2.0/certbot/CHANGELOG.md PR: 284799 Approved by: maintainer timeout
28 lines
1.5 KiB
Text
28 lines
1.5 KiB
Text
--- certbot_dns_cloudflare/_internal/dns_cloudflare.py.orig 2025-02-11 19:57:38 UTC
|
|
+++ certbot_dns_cloudflare/_internal/dns_cloudflare.py
|
|
@@ -100,12 +100,12 @@ class _CloudflareClient:
|
|
# We can't use named arguments in this case, as it would break compatibility with
|
|
# the Cloudflare library since version 2.10.1, as the `token` argument was used for
|
|
# tokens and keys alike and the `key` argument did not exist in earlier versions.
|
|
- self.cf = CloudFlare.CloudFlare(email, api_key)
|
|
+ self.cf = CloudFlare.CloudFlare(email, api_key, warnings=False)
|
|
else:
|
|
# If no email was specified, we're using just a token. Let's use the named argument
|
|
# for simplicity, which is compatible with all (current) versions of the Cloudflare
|
|
# library.
|
|
- self.cf = CloudFlare.CloudFlare(token=api_token)
|
|
+ self.cf = CloudFlare.CloudFlare(token=api_token, warnings=False)
|
|
|
|
def add_txt_record(self, domain: str, record_name: str, record_content: str,
|
|
record_ttl: int) -> None:
|
|
--- setup.py.orig 2025-02-11 19:57:39 UTC
|
|
+++ setup.py
|
|
@@ -9,7 +9,7 @@ install_requires = [
|
|
install_requires = [
|
|
# for now, do not upgrade to cloudflare>=2.20 to avoid deprecation warnings and the breaking
|
|
# changes in version 3.0. see https://github.com/certbot/certbot/issues/9938
|
|
- 'cloudflare>=2.19, <2.20',
|
|
+ 'cloudflare>=2.19, <=2.20',
|
|
]
|
|
|
|
if os.environ.get('SNAP_BUILD'):
|