mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
PoseLib provides a collection of minimal solvers for camera pose estimation. The focus is on calibrated absolute pose estimation problems from different types of correspondences (e.g. point-point, point-line, line-point, line-line). The goals of this project are to provide - Fast and robust implementation of the current state-of-the-art solvers. - Consistent calling interface between different solvers. - Minimize dependencies, both external (currently only Eigen) and internal. Each solver is (mostly) stand-alone, making it easy to extract only a specific solver to integrate into other frameworks. - Robust estimators (based on LO-RANSAC) that just works out-of-the-box for most cases. WWW: https://github.com/PoseLib/PoseLib
15 lines
601 B
Text
15 lines
601 B
Text
--- CMakeLists.txt.orig 2024-12-09 12:10:16 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -28,10 +28,10 @@ else()
|
|
# If you change this, make sure to update the corresponding line in the pybind CMakeLists
|
|
if (MARCH_NATIVE)
|
|
target_compile_options(${LIBRARY_NAME} PRIVATE
|
|
- -march=native -Wall -Werror -fPIC -Wno-ignored-optimization-argument)
|
|
+ -march=native -Wall -fPIC -Wno-ignored-optimization-argument)
|
|
else()
|
|
target_compile_options(${LIBRARY_NAME} PRIVATE
|
|
- -Wall -Werror -fPIC)
|
|
+ -Wall -fPIC)
|
|
endif()
|
|
if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
|
|
target_compile_options(${LIBRARY_NAME} PRIVATE
|