mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
This prepares the terrain and makes it in sync with the upcoming Qt5 version of the port that needs a more recent version than 0.9.2. There has been no official 0.9.3 yet, so all distributions are packaging Launchpad snapshots of the port. In addition to that: - Rename the GENDOCS option to the more standard DOXYGEN. - Simplify options handling. Most of the work has been done in our experimental area51 repository by Tobias C. Berner <tcberner@gmail.com>, thanks a lot!
20 lines
599 B
Text
20 lines
599 B
Text
--- CMakeLists.txt
|
|
+++ CMakeLists.txt
|
|
@@ -86,7 +86,7 @@ add_dependencies(distcheck dist)
|
|
configure_file(dbusmenu-qt.pc.in ${CMAKE_BINARY_DIR}/dbusmenu-${QT_SUFFIX}.pc @ONLY)
|
|
|
|
install(FILES ${CMAKE_BINARY_DIR}/dbusmenu-${QT_SUFFIX}.pc
|
|
- DESTINATION ${LIB_DESTINATION}/pkgconfig
|
|
+ DESTINATION libdata/pkgconfig
|
|
)
|
|
|
|
add_subdirectory(src)
|
|
@@ -103,7 +106,7 @@ if(WITH_DOC)
|
|
)
|
|
|
|
install(DIRECTORY ${CMAKE_BINARY_DIR}/html/
|
|
- DESTINATION share/doc/libdbusmenu-${QT_SUFFIX}-doc
|
|
+ DESTINATION share/doc/libdbusmenu-${QT_SUFFIX}
|
|
)
|
|
endif(WITH_DOC)
|
|
|