mirror of
https://git.freebsd.org/ports.git
synced 2025-05-17 17:43:11 -04:00
switch patch-files to mysql80-server to make it easy for maintain. Bugfix: - CMake now enables use of fastcov if it is available. fastcov is faster than lcov or gcov. This requires GCC and gcov versions of 9 or higher. - The DISABLE_SHARED CMake option was unused and has been removed. - The CMake code to find Protobuf executables now works on platforms that split these into multiple packages. - The new ADD_GDB_INDEX CMake option determines whether to enable generation of a .gdb_index section in binaries, which makes loading them in a debugger faster. The option is disabled by default. It has no effect if a linker other than lld or GNU gold is used. - For the INSTALL_LAYOUT CMake option, the SLES and WIN option values were not used and have been removed. - The max_prepared_stmt_count system variable maximum value has been increased from 1 million (1,048,576) to 4 million (4,194,304). The default value remains unchanged at 16,382. - MySQL 8.0 no longer supports building using wolfSSL. All MySQL builds now use OpenSSL. - The RE2 library is no longer used by MySQL. The library is no longer bundled with source distributions and the WITH_RE2 CMake option is obsolete. More Infos: https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-18.html A big thanks to @fluffy for his help with this update MFH: 2020Q1 Security: fc91f2ef-fd7b-11e9-a1c7-b499baebfeaf Sponsored by: Netzkommune GmbH
11 lines
312 B
Text
11 lines
312 B
Text
--- plugin/x/CMakeLists.txt.orig 2019-09-20 08:30:51 UTC
|
|
+++ plugin/x/CMakeLists.txt
|
|
@@ -77,6 +77,8 @@ INCLUDE_DIRECTORIES(
|
|
${MYSQLX_GENERATE_DIR}
|
|
${MYSQLX_PROTOCOL_INCLUDE_DIR}
|
|
${MYSQLX_CLIENT_INCLUDE_DIR}
|
|
+ ${OPENSSL_INCLUDE_DIR}
|
|
+ ${BOOST_INCLUDE_DIR}
|
|
)
|
|
|
|
MY_INCLUDE_SYSTEM_DIRECTORIES(PROTOBUF)
|