ports/misc/llama-cpp/files/patch-ggml_src_CMakeLists.txt
Yuri Victorovich 4e02f4adba misc/llama-cpp: update 4409 → 4418
Reported by:	portscout
2025-01-05 20:01:04 -08:00

20 lines
884 B
Text

- workaround for https://github.com/ggerganov/llama.cpp/issues/11095
--- ggml/src/CMakeLists.txt.orig 2025-01-06 00:37:35 UTC
+++ ggml/src/CMakeLists.txt
@@ -152,15 +152,6 @@ endif()
# posix_memalign came in POSIX.1-2001 / SUSv3
# M_PI is an XSI extension since POSIX.1-2001 / SUSv3, came in XPG1 (1985)
-# Somehow in OpenBSD whenever POSIX conformance is specified
-# some string functions rely on locale_t availability,
-# which was introduced in POSIX.1-2008, forcing us to go higher
-if (CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
- add_compile_definitions(_XOPEN_SOURCE=700)
-else()
- add_compile_definitions(_XOPEN_SOURCE=600)
-endif()
-
# Data types, macros and functions related to controlling CPU affinity and
# some memory allocation are available on Linux through GNU extensions in libc
if (CMAKE_SYSTEM_NAME MATCHES "Linux" OR CMAKE_SYSTEM_NAME MATCHES "Android")