ports/math/openblas64/files/patch-exports_Makefile
Thierry Thomas f1fc728ac5 math/openblas64: new port, OpenBLAS with 8 byte integers
Remark 1: CMake support is experimental. It does not yet support all build
options, but the 64 bits libraries can be installed without conflict with the
classic version.

Remark 2: some tests fail on -CURRENT "SIGSEGV: Segmentation fault -
invalid memory reference.". It seems caused by clang-18 and threads.
2024-06-08 20:41:55 +02:00

11 lines
407 B
Text

--- exports/Makefile.orig 2024-04-04 20:26:04 UTC
+++ exports/Makefile
@@ -234,7 +234,7 @@ endif
endif
$(CC) $(CFLAGS) $(LDFLAGS) -shared -o ../$(LIBSONAME) \
-Wl,--whole-archive $< -Wl,--no-whole-archive \
- $(FEXTRALIB) $(EXTRALIB)
+ -Wl,-soname,$(LIBSONAME) $(FEXTRALIB) $(EXTRALIB)
$(CC) $(CFLAGS) $(LDFLAGS) -w -o linktest linktest.c ../$(LIBSONAME) $(FEXTRALIB) && echo OK.
rm -f linktest