mirror of
https://git.freebsd.org/ports.git
synced 2025-05-02 19:46:41 -04:00
31 lines
1.2 KiB
Text
31 lines
1.2 KiB
Text
--- CMakeLists.txt.orig 2024-08-25 06:24:59 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -116,7 +116,7 @@ if (NOT MSVC)
|
|
endif()
|
|
FetchContent_MakeAvailable(llhttp-local)
|
|
if (BUILD_SHARED_LIBS)
|
|
- set(llhttp_target llhttp_shared)
|
|
+ set(llhttp_target llhttp)
|
|
else()
|
|
set(llhttp_target llhttp_static)
|
|
endif()
|
|
@@ -128,8 +128,8 @@ if (NOT MSVC)
|
|
endif()
|
|
if (OPENDHT_PROXY_OPENSSL)
|
|
# https://cmake.org/cmake/help/latest/module/FindOpenSSL.html
|
|
- pkg_search_module(OPENSSL REQUIRED IMPORTED_TARGET openssl)
|
|
- if (OPENSSL_FOUND)
|
|
+ #pkg_search_module(OPENSSL REQUIRED IMPORTED_TARGET openssl)
|
|
+ if (TRUE OR OPENSSL_FOUND)
|
|
message(STATUS "Found OpenSSL ${OPENSSL_VERSION} ${OPENSSL_INCLUDE_DIRS}")
|
|
set(openssl_lib ", openssl")
|
|
else ()
|
|
@@ -405,7 +405,7 @@ else()
|
|
target_link_libraries(opendht PUBLIC PkgConfig::Jsoncpp)
|
|
endif()
|
|
if (OPENDHT_PROXY_OPENSSL)
|
|
- target_link_libraries(opendht PUBLIC PkgConfig::OPENSSL)
|
|
+ target_link_libraries(opendht PRIVATE ssl)
|
|
endif()
|
|
if (liburing_FOUND)
|
|
set(iouring_lib ", liburing")
|