ports/www/tidy-devel/files/patch-build_gmake_Makefile
Thierry Thomas edba2db034 Backport the fix from www/tidy-html5.
PR:		ports/200631
Submitted by:	Walter Hop
Security:	VuXML: bd1ab7a5-0e01-11e5-9976-a0f3c100ae18
2015-06-08 18:06:06 +00:00

33 lines
997 B
Text

--- build/gmake/Makefile.orig 2008-03-22 21:13:38 UTC
+++ build/gmake/Makefile
@@ -58,8 +58,8 @@ SHELL=/bin/sh
PROJECT=tidy
# Installation variables. Spaces OK, only dir create and file copy operations.
-runinst_prefix=/usr/local
-devinst_prefix=/usr/local
+runinst_prefix=${PREFIX}
+devinst_prefix=${PREFIX}
bininst = ${runinst_prefix}/bin
libinst = ${devinst_prefix}/lib
@@ -67,7 +67,7 @@ incinst = ${devinst_prefix}/include/$(PR
maninst = ${devinst_prefix}/man
# Internal variables. - No spaces allowed: libtool chokes on spaces in directory names.
-TOPDIR = ../..
+TOPDIR = .
INCDIR = ${TOPDIR}/include
APPDIR = ${TOPDIR}/console
SRCDIR = ${TOPDIR}/src
@@ -90,8 +90,8 @@ DOCDIR = ${TOPDIR}/htmldoc
# CFLAGS etc..
# For optimised builds, flags such as "-O2" should be added and -D_DEBUG=1
# disabled.
-CC= gcc
-CFLAGS= -g -pedantic -Wall -I $(INCDIR)
+#CC= gcc
+CFLAGS+= -pedantic -Wall -I $(INCDIR) -fPIC
# flags only supported with gcc 3.x
CFLAGS += -Wunused-parameter