mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 15:51:51 -04:00
When installing package of databases/redis62, following pkg-message is displayed. To setup "redis62" you need to edit the configuration file: /usr/local/etc/redis62.conf To run redis from startup, add redis62_enable="YES" in your /etc/rc.conf. But path of configuration file is /usr/local/etc/redis.conf and what should really be added to /etc/rc.conf is redis_enable="YES". Same problem also happens when installing databases/redis6 The source of the problem is that the value of ${PORTNAME} is used to create pkg-message from file/pkg-message.in. So fix it by changing the value of ${PORTNAME} to "redis" and set PKGNAMESUFFIX in Makefile of each port. While I'm here, * Pet portlint and portclippy * Tidy up Makefile with portfmt. PR: 265623 Reported by: FiLiS MFH: 2022Q3
18 lines
980 B
Text
18 lines
980 B
Text
--- deps/Makefile.orig 2021-01-13 16:43:05 UTC
|
|
+++ deps/Makefile
|
|
@@ -83,12 +83,12 @@
|
|
|
|
.PHONY: lua
|
|
|
|
-JEMALLOC_CFLAGS= -std=gnu99 -Wall -pipe -g3 -O3 -funroll-loops $(CFLAGS)
|
|
+JEMALLOC_CFLAGS= -std=gnu99 -Wall -pipe -funroll-loops $(CFLAGS)
|
|
JEMALLOC_LDFLAGS= $(LDFLAGS)
|
|
|
|
jemalloc: .make-prerequisites
|
|
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
|
|
- cd jemalloc && ./configure --with-version=5.1.0-0-g0 --with-lg-quantum=3 --with-jemalloc-prefix=je_ CFLAGS="$(JEMALLOC_CFLAGS)" LDFLAGS="$(JEMALLOC_LDFLAGS)"
|
|
- cd jemalloc && $(MAKE) CFLAGS="$(JEMALLOC_CFLAGS)" LDFLAGS="$(JEMALLOC_LDFLAGS)" lib/libjemalloc.a
|
|
+ cd jemalloc && ./configure --with-version=5.1.0-0-g0 --with-lg-quantum=3 --with-jemalloc-prefix=je_ CFLAGS="$(JEMALLOC_CFLAGS)" CXXFLAGS="$(JEMALLOC_CFLAGS)" LDFLAGS="$(JEMALLOC_LDFLAGS)"
|
|
+ cd jemalloc && $(MAKE) CFLAGS="$(JEMALLOC_CFLAGS)" CXXFLAGS="$(JEMALLOC_CFLAGS)" LDFLAGS="$(JEMALLOC_LDFLAGS)" lib/libjemalloc.a
|
|
|
|
.PHONY: jemalloc
|