ports/security/py-netmiko/files/patch-pyproject.toml

30 lines
741 B
TOML

Use the more lightweight py-poetry-core instead py-poetry and relax version requirements.
--- pyproject.toml.orig 2024-07-08 22:08:10 UTC
+++ pyproject.toml
@@ -1,6 +1,6 @@
[build-system]
-requires = ["poetry>=1.6.1"]
-build-backend = "poetry.masonry.api"
+requires = ["poetry-core>=1.6.1"]
+build-backend = "poetry.core.masonry.api"
[tool.poetry]
name = "netmiko"
@@ -22,14 +22,14 @@ python = ">=3.8,<4.0"
[tool.poetry.dependencies]
python = ">=3.8,<4.0"
-setuptools = ">=65.0.0"
+setuptools = ">=63.0.0"
paramiko = ">=2.9.5"
scp = ">=0.13.6"
pyyaml = ">=5.3"
textfsm = ">=1.1.3"
ntc-templates = ">=3.1.0"
pyserial = ">=3.3"
-cffi = ">=1.17.0rc1"
+cffi = ">=1.16.0"
[tool.poetry.group.dev.dependencies]
black = "24.4.2"